Your server is running PHP version 5.0.5 but WordPress 3.8.4 requires at least 5.2.4.